CPU vulnerabilities – Meltdown and Specter

Recent press reports talk about two CPU vulnerabilities from different suppliers that have been discovered, better known under the names Meltdown (CVE-2017-5754) and Specter (CVE-2017-5753 and CVE-2017-5715).

These vulnerabilities may affect businesses and individual users because sensitive data may be obtained, however, their impact is still unclear.

In short:

1st vulnerability, called “Meltdown” applies to computer processors from manufacturer Intel, that are in almost all laptops, desktop and server systems.

2nd vulnerability, “Specter”, applies to processors from different manufacturers that are in laptops, desktop and server systems and mobile devices.

For further information, we invite you to follow the links here below, explaining the Meltdown and Specter vulnerabilities:

Software patches have been created to protect systems and products, and our technical teams have taken the necessary precautions to keep our systems as secure as possible. We are working closely with the system vendors to mitigate the potential security issues and to minimise the risk of potential attacks. However, the release of certain software patches and firmware updates is still awaited.

Labgroup will closely monitor the situation and will inform its customers about the actions taken by the technical teams.

If you require further information, we invite you to dial the number +352 350 222 999 or to send an e-mail to servicedesk@labgroup.com.